Raw H.264 Stream: fps definiton results in bad ffmpeg command



  • Example of settings and output:

    RAW H.264:
    Enabled: Yes
    Codec: libx264
    Frame Rate: 5

     -f mpegts -c:v libx2645 -s 1920x1080 http://127.0.0.1:8080/streamIn/R88IqABUaV/NcvMVzqSTh/1
    
    FFMPEG STDERR a few seconds ago
    Unknown encoder 'libx2645'
    

    I then change codec to: Copy
    Frame rate settings is now hidden, but output is:

     -f mpegts -c:v copy5 -s 1920x1080 http://127.0.0.1:8080/streamIn/R88IqABUaV/NcvMVzqSTh/1
    
    FFMPEG STDERR a few seconds ago
    Unknown encoder 'copy5'
    

    I hope my description is sufficient 🙂


  • administrators

    LOL well then... not sure how that happened. Why there is a 5 at the end of the codec name baffles me.

    Could you please try the latest dev branch? https://github.com/ShinobiCCTV/Shinobi/tree/dev



  • Just got the dev branch running, story is the same.

    The 5 is the number defined for fps, which just get written incorrectly in the ffmpeg command.
    If i leave fps setting blank, no error occurs.


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.