Recording monitors/cameras - default 1fps, small resolution?



  • So I've installed Shinobi (I'm new to Brew and have very limited use in the Terminal on OS X ), and I've managed to get it up and running and add some cameras/monitors, but when I click the record button, I only get a roughly 640x480 video at 1fps, when my cam settings are 2048x1536, 10fps, 1024 or 2056kps. I've looked high and low and can't figure out where to change the recorded video settings in Shinobi, and I've looked through the docs but haven't found anything related to my problem. Thanks for your help.

    Edit: To clarify, I've set Record to MP4, default libx264 and no audio, and I've set the record height to 2048 and width to 1536.



  • The settings boxes talked about in the docs are missing; I found that in the Monitor Settings - Record section (https://shinobi.video/docs/settings) there is Video Record Rate, Record Width, and Record Height, but I am not seeing those three items in my version of Shinobi - are these docs or my version outdated?



  • Fixed, but official docs are not corrected. Followup here in Bug Report section. https://forum.shinobi.video/topic/100/recording-fps-width-height-not-present

    For future readers of this thread, there was incorrect information in the OS X install docs, which has not been updated/fixed as of this writing. Currently (as of this reply), Step 4 - Download the Repo reports the following git code:

    git clone https://github.com/moeiscool/shinobi Shinobi && cd Shinobi
    

    However, the correct git command which has the proper build (Pro) is:

    git clone https://github.com/ShinobiCCTV/Shinobi Shinobi
    

    If you want the dev build, use -b dev:

    git clone https://github.com/ShinobiCCTV/Shinobi Shinobi -b dev
    

 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.