shinobi in raspberry pi



  • Hi, I have a working setup of zoneminder with 4 cams running. Im running the cams (old android phones) at low resolution 640x480 as I only trigger a screen in my living room to turn on if a car enters the driveway.
    Can I run shinobi on the raspberry pi 3? Are there any experiences with that? Is there an installation instruction for raspian?

    I don't like the GUI of zoneminder too much and would be happy to find a more up-to-date user experience 🙂



  • Hi, I gave it a try and installed shinobi on my rpi3 using installation instructions "ubuntu harder way".
    After running pm2 start camera.js system goes to 100% cpu usage and pm2 log gives me constantly the same error:

    0|camera | 2017-12-04T22:53:16+01:00 s.sqlQuery { Error: Cannot enqueue Query after fatal error.
    0|camera | at Protocol._validateEnqueue (/home/pi/shinobi/node_modules/mysql/lib/protocol/Protocol.js:201:16)
    0|camera | at Protocol._enqueue (/home/pi/shinobi/node_modules/mysql/lib/protocol/Protocol.js:139:13)
    0|camera | at Connection.query (/home/pi/shinobi/node_modules/mysql/lib/Connection.js:208:25)
    0|camera | at Object.s.sqlQuery (/home/pi/shinobi/camera.js:133:24)
    0|camera | at Object.s.systemLog (/home/pi/shinobi/camera.js:331:15)
    0|camera | at Query._callback (/home/pi/shinobi/camera.js:135:23)
    0|camera | at Query.Sequence.end (/home/pi/shinobi/node_modules/mysql/lib/protocol/sequences/Sequence.js:88:24)
    0|camera | at /home/pi/shinobi/node_modules/mysql/lib/protocol/Protocol.js:225:14
    0|camera | at _combinedTickCallback (internal/process/next_tick.js:73:7)
    0|camera | at process._tickDomainCallback (internal/process/next_tick.js:128:9) code: 'PROTOCOL_ENQUEUE_AFTER_FATAL_ERROR', fatal: false }

    When I try to open [RPI-IP-Address]:8080 from a browser, it just loads and loads and loads and never shows a response. When I kill camera.js the browser shows an error message that the ressource is not available. So it's running and trying to do something 🙂

    Since I'm a noob on nodejs I have no clue what this error means. Can anybody give me a hint into the right direction?


  • administrators

    oh my, im sorry i didn't see your original post almost one month ago 😞 I personally have no experience with raspberry pi 😞 In theory if it can run ubuntu, node.js, and ffmpeg. You are good to go.

    Also http://scaleway.com uses hardware similar to raspberry pi and i use them everyday. This forum is actually running on one now and this forum is NodeBB, a node.js forum engine.

    about your second post : It looks like your shinobi isn't connecting to the SQL client. Did you download this copy recently?



  • Hi, no worries about the delay of response. I also did not have so much time to play around with it.
    Generally there is a nodejs and a ffmpeg package available for raspbian as well (the raspbian I'm using is based on debian strech and therefore somehow similar to ubuntu, but not real ubuntu).
    I downloaded from your git repo this week. As said I followed the instructions as described on http://shinobi.video/docs/start (Ubuntu: The hard way).

    👍 You were right. I tried with user root and that did not work. I created a seperate account as recommended in the instructions and now it's running. CPU usage is smooth. Give me some times to play around and maybe I can give feedback to community about my experience.
    Thank you very much!


  • administrators

    yay!! please do 🙂 I like to hear about things working 😄 things not working makes me sad 😞



  • I'm interested too!
    I'm planning to build a little security around my home, without involving a minipc to run surveillance software.
    During a test, it works on a virtual machine in an old notebook.. so I want to give a try in an SBC.
    I'm searching for a good choice between price, power, ram, video capabilites; I'm looking in the new Pine Rock64, 64bit rockchip cpu with 2 Gb RAM (or 1 or 4) capable to work with 4k, hdr and so on.. so I think could be a good choice.

    I let you know if I'll decide to go for it.



  • Just to be useful to other peoples.
    As for now I made a test installation over an old Raspberry Pi B (750mhz 512mb ram), over a raspbian stretch (deb9).
    As I expected, that board is not enough powerful to let shinobi to work: a single stream [email protected] pull the CPU to 80-90% with a very bad quality, so not usable in any way.

    Installation works (harder way tested), shinobi start and it works, but adding a single video stream cause board saturation and then is not usable.

    I suggest to @moeiscool to start a pinned thread with a sort of "tested hardware" table to let people to check if someone else has tested an hardware (or a similar one), and where people can contribute with their test.

    I'll try with a Pine rock64 board one day or another 🙂
    Or simply a micro pc, but I want to avoid a dedicated pc (or an old laptop) to avoid power consumption.



  • Hi All,

    I just wanted to share my experiance with Shinobi and RaspberryPi.

    I have Shinobi installed on Raspberry Pi 3 Model B. Only radiators added, no active cooling.. Additionally I have 1TB external HDD attached for recording 14 days back.
    I have 3 cameras connected to it.
    Sricam SP009, Sricam SP012 and Xiaomi Dafang (with hack).
    All run 720p.

    All cameras are configured as source H264, RTSP and stream HLS (no audio). Additionally I have JPEG API enabled for all of them - I use it to see my cameras in home automation system Home Assistant. I had to downsize JPEG snapshot to 320x200, but it is ok for home automation system. I have full resolution whenever I need it via Shinobi. When I tried to use MJPEG, CPU usage goes up.

    With above configuration, at night when all cameras switch to black&white, Shinobi is showing max 30% of CPU usage - temperature drops below 70 degrees celcius, and during the day reaches 80 degrees and I guess downclocking is kicking in ... but it works quite well. I just occasionally need to reboot, but I think I can add active cooling to solve this.

    I am waiting for delivery of 2 additional cameras. Will see how it will work out. I'll let you know.



  • Hi there,

    I also had Shinobi running on Raspberry Pi 3 some time ago, but got my hands on a refurbished laptop, which is more powerful.
    Nevertheless, I'm still interested in applying it on the Raspberry.
    I would like to know if anybody gets the h264 acceleration of the Raspberry Pi 3 to work.
    I just found a description of how to compile ffmpeg with accelleration support. Perhaps you guys might want to check it.
    https://maniaclander.blogspot.com/2017/08/ffmpeg-with-pi-hardware-acceleration.html

    Best regards, Daniel


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.