Freenas install error



  • Tried ZM and cannot get it to record video. Came across this and was investigating. Created a new jail (Under 11.2). Cloned the repository . Tried to ;translate' between teh Ubunti Hard way and FreeBSD Jail. Could not get it to work. Started over. created a fresh jail, Cloned the git. Chmodded repository to 755. Went to INSTALL dir and ran ./Freenas. It appeared to install most things. The very end of the script had errors

    Receiving objects: 100% (877/877), 14.83 MiB | 1020.00 KiB/s, done.
    Resolving deltas: 100% (270/270), done.
    Adding Shinobi user to database...
    mysql: Command not found.
    ehco: Command not found.
    mysql: Command not found.
    Securing mysql...
    npm: Command not found.
    npm: Command not found.
    pm2: Command not found.
    pm2: Command not found.
    pm2: Command not found.
    pm2: Command not found.
    pm2: Command not found.
    ||===== Install Completed =====||
    || Login with the Superuser and ||
    || create a new user at ||
    || http://THIS_JAIL_IP:8080/super ||
    || Superuser : [email protected] ||
    || Default Password : admin ||

    Went to the script and manually ran the commands and they
    appeared to run successfully. I was able to log into the
    /super web page but cannot create a user and cannot log
    in to the main page to (I am guessing) set up cameras.

    Sorry for the formatting, I am trying to figure out how to format this intelligibly. How does one add 'CODE' formatting?



  • Finally got it installed.
    Installed the current port of ffmpeg with the correct compile flags set.
    Had to run the freenas.script again to get it installed so I could log into the super web page and set myself up as a user.

    to whomever is maintaining the freenas install scriot, you need to add a couple things. 1 python 2.7 is installed as /usr/local/bin/python27. I set my environment variable for PYTHON to this to allow the installation of a couple of the node.js packages. I had to reinstall a couple packages:
    npm install [email protected]
    npm install socket.io@2.2.0
    I had to go to the plugins/motion directory and copy the conf.sample.json to conf.json manually as the motion install script expects ubuntu/linux and not freebsd
    I had to set my PYTHON env var and then npm install canvas

    At this point, I am up and runnig with 2 cameras: a POE camera and a usb camera on a remote RPi with the stream sent out by motion-project. Took me a bit to get the mjpeg set up but it seems to be working now.

    Now for fine tuning.

    Thanks for the software


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.