Help with HW Acceleration...



  • I am attempting to reconfigure my Shinobi installation to support HW Acceleration. I am using an Nvidia GT 610 and have installed the Nvidia 390 drivers with cuda support.

    +-----------------------------------------------------------------------------+
    | NVIDIA-SMI 390.30 Driver Version: 390.30 |
    |-------------------------------+----------------------+----------------------+
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    |===============================+======================+======================|
    | 0 GeForce GT 610 Off | 00000000:05:00.0 N/A | N/A |
    | 40% 45C P0 N/A / N/A | 0MiB / 961MiB | N/A Default |
    +-------------------------------+----------------------+----------------------+

    +-----------------------------------------------------------------------------+
    | Processes: GPU Memory |
    | GPU PID Type Process name Usage |
    |=============================================================================|
    | 0 Not Supported |
    +-----------------------------------------------------------------------------+

    nvcc: NVIDIA (R) Cuda compiler driver
    Copyright (c) 2005-2017 NVIDIA Corporation
    Built on Fri_Nov__3_21:07:56_CDT_2017
    Cuda compilation tools, release 9.1, V9.1.85

    I attempted to change one of my streams as follows:
    0_1546754499201_a6d94c33-15ab-490c-b6c1-48e6e928c2bb-image.png

    After which I am prompted with....

    FFMPEG STDERR
    a few seconds ago
    cuvid hwaccel requested for input stream #0:0, but cannot be initialized.

    Any suggestions on where to start?



  • "The GeForce GT 610 card is a rebranded GeForce GT 520."

    Your card is a "GF119-300-A1".

    "If the codename of your graphic card begins with GK (Kepler microarchitecture), GM (Maxwell microarchitecture) or GP (Pascal microarchitecture) then your graphic card does support NVENC; if not then your graphic card does not support NVENC"

    You do not have a built in H264 encoder on your GPU and will not be able to use NVIDIA NVENC.



  • https://developer.nvidia.com/video-encode-decode-gpu-support-matrix

    Please refer to this list for NVENC capable cards. (There's a complete list button down the bottom, just click "GeForce/TITAN"


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.