Latest Shinobi Pro freezes on page load with a monitor configured



  • I was originally using Shinobi CE, but ran into issues (https://forum.shinobi.video/topic/325/motion-event-not-triggering-video-record). So I decided to switch to Pro just to see if it has already solved my problem and not been backported to CE. Unfortunately I ran into a new problem with Pro.

    Whenever I log in, the page becomes unresponsive withing a second or two of loading. I can't click anything, and Chrome eventually tells me the page is unresponsive and offers to kill it. Waiting longer does not solve the problem. Occasionally more elements will load for a moment, but then just freeze again (although this does not happen often; only a few times). I've waited upwards of 10 minutes without the page ever starting to work.

    I've tried in Desktop Chrome (linux), Android Chrome, and I've also tried in desktop Firefox. Generally the same freezing behavior in all of them, although Firefox seems a little more likely to load more page elements a minute or so later, but it too always becomes unresponsive again.

    Its not consistent in where the browser freezes up. Sometimes all the elements of the page load and I'll get my video feed, and then things become unresponsive; other times it freezes before loading all elements, like in:

    0_1543079691347_shinobi-frozen.png

    I've tested with a clean database, and if I don't have any monitors, everything is fine. I can go through the process of adding a monitor, and as soon as it starts to load, it freezes.

    Whenever its frozen I can kill the page, go back to the URL, and get a login prompt that is responsive. If I log in again the problem just happens again.

    Whenever its frozen the admin and super pages are entirely responsive and I can do whatever I want there.

    I'm running in a container - a self-rolled container, not the official Shinobi container - and it has plenty of resources and no signs of anything being blocked. All processes are in normal states, I can use strace on the node processes and they're humming along reading and writing. I see the resource-monitoring child processes firing off throughout all of this and getting reaped. ffmpeg processes are running and not seeming to be unresponsive.

    I tried going back in the commit history to see if I could pinpoint where this starting showing up - hoping that it was a recent commit. I've gone back as far as f3d60ca6 and the problem still occurred.

    This is not happening for me using CE with the same environment and container setup.

    Any ideas? I am happy to provide any additional info, help troubleshoot, run tests, etc.

    Thanks



  • Well I just went back as far as commit 0e1f60a4 and its not having the problem. So let me see if I can further narrow it down from there. Stand-by...



  • Oddly, it seems to be:

    commit a1e3995dac51c1735c1c58c88990cd53655e2450
    Author: Moe <[email protected]>
    Date:   Wed Oct 17 10:11:00 2018 -0700
    
        Use 24-Hour in daterangepickers
    

    I arrived at this one through trial-and-error:

    f3d60ca6 02 Nov PROBLEM
    7afc0429 21 Oct PROBLEM
    53fec707 18 Oct PROBLEM
    623e916d 18 Oct PROBLEM
    a1e3995d 17 Oct PROBLEM <--
    3159102d 16 Oct NO PROBLEM
    2c9282e9 13 Oct NO PROBLEM
    0e1f60a4 01 Oct NO PROBLEM

    I've tested 3159102d repeatedly, and it works fine every time. I've been running it and using it extensively for 20+ minutes now without any issue. If I run a1e3995d or later, it freezes every time.

    I switched back to the latest commit and selectively reverted a1e3995d and it did not resolve the problem - freezing continued. I also tried individually setting timePicker24Hour and timePickerSeconds to false, and both of them false, and the problem continued. So I don't know what's going on with that commit, but it begins right there.

    ¯\(°_o)/¯



  • Just wanted to report that I'm experiencing the same thing as jrummy.

    I'm currently running Shinobi Pro on Proxmox in a container (unofficial) with plenty of resources (CPU, RAM), but my browser freezes consistently when loading any monitors, and I end up with the same empty web GUI, then need to kill the page. I've tried multiple browsers. Occasionally, I can get to monitor settings, but after saving any new settings, I experience the freeze again.

    I've reverted to 3159102d like jrummy suggested and things seem to be working better so far.

    A little more info... I recently re-did my Shinobi set-up (new installation, new environment, etc.) and don't remember running into these problems the first time I installed Shinobi. I'm using the same IP cameras and settings from my initial install.

    Will investigate more when time permits.

    Appreciate all the work put into Shinobi. It's a great product.


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.