Mobile access (iphone)

  • Hello,
    I've just installed Shinobi CCTV onto Ubuntu 18.04. Seems to work pretty well after going through some learning steps.

    I've read that it should be as easy as opening shinobi on a web browser for a mobile device, however that is not working for me.

    I can view the monitors, time lapse, etc... on my laptop. But on my iPhone, the monitor video (or recordings) simply don't show. I've tried all different combinations of the stream settings but on Safari for the iPhone it isn't working. It works on Safari for the laptop.

    I have not tried a different browser on the iPhone.

    Has anyone gotten it to work on an iPhone?

  • I have a similar problem, am unable to view an expended monitor view on the right side of the interface. Notice the "can't play" icon in the included image.

    The thumbnails on the right of the screen appear, and I can view videos from the Videos List. However, the Pop and Fullscreen options do nothing. I use Firefox for iOS, but I believe the behaviour is the same with Safari, on both an iPhone and iPad at iOS 12.

    Any suggestions as to a cause?
    Anybody with an iOS device have Shinobi working for them?



  • Got the same issue on both my iPhones... I can't see live video (stays black). Yet I can watch/see the recorded video's.

  • I have exactly the same problem. The screen just stays black when opening a monitor, regardless of the browser on iOS. Is there any fix for this?

  • I wonder if the dashboard view is presenting the live video in a format that iOS can't natively handle?

    I've not had time to investigate the issue, but maybe it depends on the stream type your camera(s) have been configured to send, or some such. Perhaps most folks employ something that works in iOS, but us unlucky few chose (or had no choice?) an incompatible type?

    I wish we'd get some replies saying "works fine for me in iOS", otherwise we don't even know whether it doesn't work for anybody.

  • but I want to choose port for Shinobi (having my domoticz running on 8080). Which installation method would you recommend for Qnap and then how to choose port during the installation? DigitalOcean SiteGround iPage

  • Check out this topic over at Reddit, the post there explains the issue well and helped me resolve the problem (I went with the VLC option, just because).

    Note that Reddit appears to be a more robust discussion forum for Shinobi issues.


Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.