Adding swads-446cam



  • Hi, shinobi newbie here.
    Just trying Shinobi & having probs getting ip swan swads-446cam working. I have also tested ZoneMinder & Xeoma & got the cam running on both of these. But I'm obviously doing something wrong in the setup Input feilds. Setting that worsk on Xeoma: [1280x720 25 fps h264 512Kb] rtsp://192.168.2.41/Streaming/Channels/1?transportmode=unicast&profile=Profile_1
    Any advice appreciated.
    Thanks
    Garry


  • administrators

    Can you please hit export on your monitor settings then upload the json file here.

    Usually the culprit is the audio codec. I suggest doing AAC if you want audio and if not to set to No Audio.

    Since you have an RTSP camera you can follow along on this guide http://shinobi.video/articles/2017-08-22-view-h264-and-h265-streams-in-the-browser-with-shinobi-and-maintain-low-cpu-use



  • Hi thanks 4 reply. c below export of monitor

    {"mode":"start","mid":"GhlfiTi2Kz","name":"Swan40","type":"h264","protocol":"rtsp","host":"192.168.2.40","port":"554","path":"/Streaming/Channels/1?transportmode=unicast&profile=Profile_1","ext":"mp4","fps":"1","width":"640","height":"480","details":"{"fatal_max":"","notes":"","dir":"","rtsp_transport":"http","muser":"admin","mpass":"mypassword","port_force":null,"sfps":"1","aduration":"1000","probesize":"1000","accelerator":null,"hwaccel":null,"hwaccel_vcodec":"","hwaccel_device":"","stream_type":"hls","stream_mjpeg_clients":"","stream_vcodec":"no","stream_acodec":"no","hls_time":"2","preset_stream":"ultrafast","hls_list_size":"3","signal_check":"10","signal_check_log":"0","stream_quality":"15","stream_fps":"2","stream_scale_x":"1280","stream_scale_y":"720","rotate_stream":null,"svf":"","stream_timestamp":null,"stream_timestamp_font":"","stream_timestamp_font_size":"","stream_timestamp_color":"","stream_timestamp_box_color":"","stream_timestamp_x":"","stream_timestamp_y":"","stream_watermark":null,"stream_watermark_location":"","stream_watermark_position":null,"snap":"1","snap_fps":"","snap_scale_x":"","snap_scale_y":"","snap_vf":"","vcodec":"libx264","crf":"1","preset_record":"","acodec":"none","dqf":"0","cutoff":"15","rotate_record":null,"vf":"","timestamp":"0","timestamp_font":"","timestamp_font_size":"10","timestamp_color":"white","timestamp_box_color":"[email protected]","timestamp_x":"(w-tw)/2","timestamp_y":"0","watermark":null,"watermark_location":"","watermark_position":null,"cust_input":"","cust_snap":"","cust_detect":"","cust_stream":"","cust_stream_server":"","cust_record":"","custom_output":"","detector":"0","detector_webhook":null,"detector_webhook_url":"","detector_command_enable":null,"detector_command":"","detector_command_timeout":"","detector_lock_timeout":"","detector_save":null,"detector_frame_save":null,"detector_mail":"0","detector_mail_timeout":"","detector_record_method":"del","detector_trigger":null,"detector_trigger_record_fps":"","detector_timeout":"","watchdog_reset":null,"detector_delete_motionless_videos":null,"detector_send_frames":"1","detector_fps":"","detector_scale_x":"640","detector_scale_y":"480","detector_use_motion":null,"detector_use_detect_object":null,"detector_frame":"1","detector_sensitivity":"","cords":"","detector_lisence_plate":null,"detector_lisence_plate_country":null,"detector_notrigger":null,"detector_notrigger_mail":null,"detector_notrigger_timeout":"","control":"0","control_base_url":"","control_stop":"0","control_url_stop_timeout":"","control_url_center":"","control_url_left":"","control_url_left_stop":"","control_url_right":"","control_url_right_stop":"","control_url_up":"","control_url_up_stop":"","control_url_down":"","control_url_down_stop":"","control_url_enable_nv":"","control_url_disable_nv":"","control_url_zoom_out":"","control_url_zoom_out_stop":"","control_url_zoom_in":"","control_url_zoom_in_stop":"","groups":"[]","loglevel":"warning","sqllog":"0","detector_cascades":""}","shto":"[]","shfr":"[]"}


  • administrators

    0_1507241852251_Shinobi_GhlfiTi2Kz_config (1).json try that. I modified the video codec to be copy instead.

    can you also confirm your ffmpeg version please, should be version 3+

    Also how did you get that string? It is an invalid output of the string.. 😕



  • @moeiscool
    Hi thanks, but no luck. I imported saved & no video
    ffmpeg 7:3.3.4-2~16.04.york0 amd64

    The string was the one that worked in Xeoma that it auto detected when scanning to add monitor.


  • administrators

    can you please check your logs. Click the triangle located on the stream window and it should reveal the log stream pane.

    If that does not show anything open the monitor settings and turn set Logging to Save to SQL with the level at Warning.

    Once done that open up the Logs window found by clicking your username in the top left then Logs.


  • administrators

    also if you could please probe the current settings you have now, does it give back anything?



  • @moeiscool
    Log
    2Df5hBE : GhlfiTi2Kz
    Process Unexpected Exit a few seconds ago
    msg : Process Crashed for Monitor : GhlfiTi2Kz
    cmd : -loglevel warning -analyzeduration 1000 -probesize 1000 -rtsp_transport http -i rtsp://admin:[email protected]:554/Streaming/Channels/1 -preset ultrafast -crf 15 -an -c:v copy -r 2 -f hls -s 1280x720 -tune zerolatency -g 1 -hls_time 2 -hls_list_size 3 -start_number 0 -hls_allow_cache 0 -hls_flags +delete_segments+omit_endlist /dev/shm/streams/2Df5hBE/GhlfiTi2Kz/s.m3u8 -update 1 -r 1 /dev/shm/streams/2Df5hBE/GhlfiTi2Kz/s.jpg -y
    2Df5hBE : GhlfiTi2Kz
    FFMPEG STDERR a few seconds ago
    rtsp://admin:[email protected]:554/Streaming/Channels/1: Input/output error
    2Df5hBE : GhlfiTi2Kz
    FFMPEG Process Started a few seconds ago
    cmd : -loglevel warning -analyzeduration 1000 -probesize 1000 -rtsp_transport http -i rtsp://admin:[email protected]:554/Streaming/Channels/1 -preset ultrafast -crf 15 -an -c:v copy -r 2 -f hls -s 1280x720 -tune zerolatency -g 1 -hls_time 2 -hls_list_size 3 -start_number 0 -hls_allow_cache 0 -hls_flags +delete_segments+omit_endlist /dev/shm/streams/2Df5hBE/GhlfiTi2Kz/s.m3u8 -update 1 -r 1 /dev/shm/streams/2Df5hBE/GhlfiTi2Kz/s.jpg -y
    2Df5hBE : GhlfiTi2Kz

    When I pobe I get nil result

    Thanks


  • administrators

    I see

    2Df5hBE : GhlfiTi2Kz
    FFMPEG STDERR a few seconds ago
    rtsp://admin:[email protected]:554/Streaming/Channels/1: Input/output error
    

    this could mean your camera is incapable of serving more than one client at a time. If you have VLC or some other program pulling the stream from the camera it could be meeting a hardware limitation.

    I have a 2 HOSAFE cameras and both only allow one connection at a time. They simply crash if more is attempted. Perhaps yours is smarter, rather than crashing it just disallows the stream to take place.



  • @moeiscool said in Adding swads-446cam:

    I see

    2Df5hBE : GhlfiTi2Kz
    FFMPEG STDERR a few seconds ago
    rtsp://admin:[email protected]:554/Streaming/Channels/1: Input/output error
    this could mean your camera is incapable of serving more than one client at a time. If you have VLC or some other program pulling the stream from the camera it could be meeting a hardware limitation.
    

    Hi, Perhaps, but I have 2 swads-446 both working with testing setups of (linux) Xemoa, Ivideon & (windose) Blue Iris.

    Its my first time installing & setting up these servers & cams so I'm prob doing something wrong when it comes to Shinobi.

    What is the correct way to start stop the server?
    pm2 start camera.js - pm2 stop camera.js
    are that any other services that should be started?

    One of the cameras did work with Shinobi, but only for a few min and only when I logged in via the default account.

    Thanks 4 your help


  • administrators

    camera.js is technically the only process you need to start, cron isn't needed unless you use filters or have videos getting older sooner than your storage maxing.

    pm2 stop camera.js && pm2 start camera.js
    

    inside the shinobi folder. is how you stop and start.

    The one that worked can you post the settings for that here please.


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.