RTSP camera acting... weird



  • I have 2 SCICAM cam cameras, they allow RTSP viewing of the stream and this works on other NVR software setups but in Shinobi they act strangely, the little iconified preview works but it goes in and out, and if I pull up the main view it's just black.
    Log Excerpt:
    WbmnoWrl6j : sricam
    Process Unexpected Exit 9 minutes ago
    msg : Process Crashed for Monitor : sricam
    cmd : -loglevel warning -r 12 -analyzeduration 1000000 -probesize 1000000 -fflags +igndts -rtsp_transport tcp -hwaccel auto -i "rtsp://x.x.x.x/onvif1" -vcodec libx264 -r 1 -s 1280x720 -f segment -segment_atclocktime 1 -reset_timestamps 1 -strftime 1 -segment_list pipe:2 -segment_time 900 "/media/camera/warehouse/shin/Shinobi/videos/WbmnoWrl6j/sricam/%Y-%m-%dT%H-%M-%S.mp4" -preset ultrafast -c:v copy -f hls -hls_time 2 -hls_list_size 3 -start_number 0 -hls_allow_cache 0 -hls_flags +delete_segments+omit_endlist "/dev/shm/streams/WbmnoWrl6j/sricam/s.m3u8"

    0_1528581069709_Selection_009.png



  • Did you try different stream types? I'm using RTSP and I have best results with Stream Type "HLS (includes audio)" and Video Encoder set to "auto". Also you could try reducing the bitrate of your camera.



  • nothing is working fro me.. i am getting the same error



  • I just activated motion detection and now I get the same error. Could you try disabling motion detection and see if that is causing the problem? Go to global detector settings and change enabled to "no".

    Process Unexpected Exit a few seconds ago
    msg : Process Crashed for Monitor : OT76IITTIW
    cmd : -loglevel warning -analyzeduration 1000000 -probesize 1000000 -fflags +igndts -rtsp_transport tcp -i "rtsp://my_name:[email protected]:554/11" -preset ultrafast -an -f hls -r 2 -crf 15 -tune zerolatency -g 1 -hls_time 2 -hls_list_size 3 -start_number 0 -hls_allow_cache 0 -hls_flags +delete_segments+omit_endlist "/dev/shm/streams/kjmjRpgFKp/OT76IITTIW/s.m3u8" -an -c:v pam -pix_fmt gray -f image2pipe -vf fps=2 -s 640x480 pipe:3 -c:a copy -c:v copy -f hls -tune zerolatency -g 1 -hls_time 2 -hls_list_size 4 -start_number 0 -live_start_index -3 -hls_allow_cache 0 -hls_flags +delete_segments+omit_endlist "/dev/shm/streams/kjmjRpgFKp/OT76IITTIW/detectorStream.m3u8"
    

 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.