Problems installing on Ubuntu 16.04



  • Hi all,

    I'm having issues installing. My OS is Ubuntu 16.04. I'm currently running Zoneminder, and like many others, have decided it's time for an upgrade.

    I've tried a couple of install methods and none have worked for me... More info:

    [email protected]:~$ nodejs -v
    v8.11.1

    [email protected]:~$ node -v
    v9.10.1

    [email protected]:~$ ffmpeg -version
    ffmpeg version 2.8.11-0ubuntu0.16.04.1 Copyright (c) 2000-2017 the FFmpeg developers
    built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.4) 20160609
    configuration: --prefix=/usr --extra-version=0ubuntu0.16.04.1 --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-libx264 --enable-libopencv
    libavutil 54. 31.100 / 54. 31.100
    libavcodec 56. 60.100 / 56. 60.100
    libavformat 56. 40.101 / 56. 40.101
    libavdevice 56. 4.100 / 56. 4.100
    libavfilter 5. 40.101 / 5. 40.101
    libavresample 2. 1. 0 / 2. 1. 0
    libswscale 3. 1.101 / 3. 1.101
    libswresample 1. 2.101 / 1. 2.101
    libpostproc 53. 3.100 / 53. 3.100

    I think this is part of my issue:

    [email protected]:~$ sudo apt-get install npm
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies.
    npm : Depends: nodejs but it is not going to be installed
    Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
    Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
    Depends: node-ansi-color-table but it is not going to be installed
    Depends: node-archy but it is not going to be installed
    Depends: node-block-stream but it is not going to be installed
    Depends: node-fstream (>= 0.1.22) but it is not going to be installed
    Depends: node-fstream-ignore but it is not going to be installed
    Depends: node-github-url-from-git but it is not going to be installed
    Depends: node-glob (>= 3.1.21) but it is not going to be installed
    Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
    Depends: node-inherits but it is not going to be installed
    Depends: node-ini (>= 1.1.0) but it is not going to be installed
    Depends: node-lockfile but it is not going to be installed
    Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
    Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
    Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
    Depends: node-gyp (>= 0.10.9) but it is not going to be installed
    Depends: node-nopt (>= 3.0.1) but it is not going to be installed
    Depends: node-npmlog but it is not going to be installed
    Depends: node-once but it is not going to be installed
    Depends: node-osenv but it is not going to be installed
    Depends: node-read but it is not going to be installed
    Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
    Depends: node-request (>= 2.25.0) but it is not going to be installed
    Depends: node-retry but it is not going to be installed
    Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
    Depends: node-semver (>= 2.1.0) but it is not going to be installed
    Depends: node-sha but it is not going to be installed
    Depends: node-slide but it is not going to be installed
    Depends: node-tar (>= 0.1.18) but it is not going to be installed
    Depends: node-underscore but it is not going to be installed Depends: node-which but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    I have also attempted a docker install. Here is the log:

    https://pastebin.com/Z0nXM5ga

    Any help how to install would be appreciated!

    Many thanks

    John



  • Also, is there anyway to install without trashing the Zoneminder db? I want to jump ship from ZM to Shinobi, but only when I know it fits my needs!

    Thanks

    John


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.