Trouble getting set up



  • Hey all,

    I'm attempting to install Shinobi on an Ubuntu 16.04 system by cloning the repo and running the INSTALL/ubuntu.sh script— I had to manually hack around some bugs in the setup script which resulted in wrong versions of ffmpeg and nodejs getting installed— I think all that's dealt with now, but I'm now having trouble creating the initial user.

    I would prefer to use SQLite, but I've also tried MariaDB and in both cases I navigate in my browser to the /super page, and can log in with the supplied credentials. However, I get a JavaScript error due to users=; in the source, and then a similar Cannot read property cx of undefined when I try to save the form to create the first user.

    I've tried doing this with the current master branch of the CE repo, as well as the Pro release from a few weeks ago— it's the same behaviour on both, and I can't find any other discussion about this issue, so I think it must be something to do with my system rather than a widespread problem.

    Anyone have thoughts as to what might be going on?



  • Hi, check the configuration of your conf.json and super.json in your Shinobi install folder, if the files don't exists you have to copy and edit the .sample.json version.

    HTH



  • Thanks for the reply!

    Upon looking a bit further, it seems like the database isn't getting set up properly— my preference would be to use SQLite, so that's what I've been trying, and the shinobi.sqlite file does seem to have some stuff in it as copied over from the sample, but the Users table is empty. Is anyone successfully using SQLite, or is it still under development?

    For MariaDB, I get the following while running sudo INSTALL/ubuntu.sh:

    =============
    Shinobi - Database Installation
    (y)es or (N)o
    y
    ERROR 1396 (HY000) at line 1 in file: 'sql/user.sql': Operation CREATE USER failed for 'majesticflame'@'127.0.0.1'
    ERROR 1006 (HY000) at line 16 in file: 'sql/framework.sql': Can't create database 'ccio' (errno: 2 "No such file or directory")
    ERROR 1049 (42000) at line 17 in file: 'sql/framework.sql': Unknown database 'ccio'
    ERROR 1046 (3D000) at line 20 in file: 'sql/framework.sql': No database selected
    ERROR 1046 (3D000) at line 31 in file: 'sql/framework.sql': No database selected
    ERROR 1046 (3D000) at line 40 in file: 'sql/framework.sql': No database selected
    ERROR 1046 (3D000) at line 49 in file: 'sql/framework.sql': No database selected
    ERROR 1046 (3D000) at line 70 in file: 'sql/framework.sql': No database selected
    ERROR 1046 (3D000) at line 79 in file: 'sql/framework.sql': No database selected
    ERROR 1046 (3D000) at line 91 in file: 'sql/framework.sql': No database selected
    

    In general, I'm finding it very confusing to understand whether the install script is meant to be run as sudo or not— there are instances of sudo in the script, which seems to imply that it should be as the unprivileged user and will escalate as required, but there are also a lot of things which will obviously fail if not already root when running it.



  • Hi, i'm using MariDB and didn't try SQLite.

    Regarding MariaDB install it should work using the installer but if not you can create the database and user manually.

    Follow the instrucctions from https://shinobi.video/docs/start#content-ubuntu--the-harder-way starting at section 7.

    I recomend you to make sure you can login in mysql from the console after create the database and user, I nedeed to use the server local IP for the mysql user, localhost and 127.0.0.1 did not work.

    so you may need to create the user as:

    CREATE USER 'majesticflame'@'LOCAL_IP OR %' IDENTIFIED BY '';
    

    instead of:

    CREATE USER 'majesticflame'@'127.0.0.1' IDENTIFIED BY '';
    

    And chage it in conf.json too.

    HTH.



  • Yes, thanks! With manually creating the database tables I was able to flush out a permissions problem and get it working. It's odd because this really is a bog standard 16.04 box, so I can't imagine how it got into this funky state, but it does seem to be okay now.

    Now I just need to get my cheapo wifi cameras to actually stay up long enough to be recorded from, heh.


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.