PM2 error log for Shinobi



  • Hello again,
    I have Shinobi running on a Odroid XU4 with Ubuntu 16.04 LTS. It seems to be happily running on its own, with plug-in motion detection, deleting no motion recording and emailing notices for detecting motion. I however am receiving on a consistent basis the same error reported in pm2 camera-error-0.log file. The other pm2 logs remain OK. The error reported by pm2 is:

    Uncaught Exception occured!
    TypeError: Cannot read property 'login_type' of undefined
    at Socket.<anonymous> (/home/odroid/Apps/shinobi/camera.js:3474:50)
    at emitOne (events.js:116:13)
    at Socket.emit (events.js:211:7)
    at Socket.emit (/home/odroid/Apps/shinobi/node_modules/socket.io/lib/socket.js:141:10)
    at Socket.onclose (/home/odroid/Apps/shinobi/node_modules/socket.io/lib/socket.js:441:8)
    at Client.onclose (/home/odroid/Apps/shinobi/node_modules/socket.io/lib/client.js:235:24)
    at emitTwo (events.js:131:20)
    at Socket.emit (events.js:214:7)
    at Socket.onClose (/home/odroid/Apps/shinobi/node_modules/engine.io/lib/socket.js:311:10)
    at Object.onceWrapper (events.js:313:30)
    at emitNone (events.js:106:13)
    at WebSocket.emit (events.js:208:7)
    at WebSocket.Transport.onClose (/home/odroid/Apps/shinobi/node_modules/engine.io/lib/transport.js:127:8)
    at Object.onceWrapper (events.js:317:30)
    at emitTwo (events.js:126:13)
    at WebSocket.emit (events.js:214:7)

    I have tried to track the source of this down but can not make any sense of where it is coming from or why. Any hints or assistance to resolve this is appreciated.



  • Installing the new update (Mar 14/18) solved this issue, but this update has bought forth another issue that will be discussed in another post


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.