[Solved-Partially]Fresh install - ubuntu Svr 17.04 - NPM Errors



  • thinking I did something wrong on a fresh install UBNT Server 17.04
    system utilities and openssh only
    then apt update && apt upgrade then start setup on:
    http://shinobi.video/docs/start

    didn't find solution just yet - but errors abound at

    apt install npm -y

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    npm : Depends: nodejs but it is not going to be installed
    Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
    Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
    Depends: node-ansi-color-table but it is not going to be installed
    Depends: node-archy but it is not going to be installed
    Depends: node-block-stream but it is not going to be installed
    Depends: node-fstream (>= 0.1.22) but it is not going to be installed
    Depends: node-fstream-ignore but it is not going to be installed
    Depends: node-github-url-from-git but it is not going to be installed
    Depends: node-glob (>= 3.1.21) but it is not going to be installed
    Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
    Depends: node-inherits but it is not going to be installed
    Depends: node-ini (>= 1.1.0) but it is not going to be installed
    Depends: node-lockfile but it is not going to be installed
    Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
    Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
    Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
    Depends: node-gyp (>= 0.10.9) but it is not going to be installed
    Depends: node-nopt (>= 3.0.1) but it is not going to be installed
    Depends: node-npmlog but it is not going to be installed
    Depends: node-once but it is not going to be installed
    Depends: node-osenv but it is not going to be installed
    Depends: node-read but it is not going to be installed
    Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
    Depends: node-request (>= 2.25.0) but it is not going to be installed
    Depends: node-retry but it is not going to be installed
    Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
    Depends: node-semver (>= 2.1.0) but it is not going to be installed
    Depends: node-sha but it is not going to be installed
    Depends: node-slide but it is not going to be installed
    Depends: node-tar (>= 0.1.18) but it is not going to be installed
    Depends: node-underscore but it is not going to be installed
    Depends: node-which but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    (ideas - figuring I missed something but not seeing it yet)



  • This post is deleted!


  • Nevermind - I should be using Ubuntu Easier way..

    think those errors are ok but want to test Community version vs Commercial License currently anyway.

    thx!


  • administrators

    ah, i really need to update the docs... or if someone reading this post is willing can do a pull request https://github.com/ShinobiCCTV/shinobi.video

    You dont need to do

    apt install npm -y
    

    because i added the prior bit about installing from the node.js repo. This auto installs npm when doing apt install nodejs


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.