Embedded Timestamp Setup?

  • How do I setup embedded timestamps? I've tried turning them on, but the path isn't correct for OS X, so I dropped in FreeSans.ttf file obtained from GNU Fonts into the Shinobi folder. How would I tell Shinobi that's where it is? Is the path /Shinobi/FreeSans.ttf, or /FreeSans.ttf, or ?

    I would prefer to use the timestamps from my Hikvision cameras (as they automatically switch from black to white letters depending on background), but I'm doing this to try and see why Shinobi thinks there is not a correct timestamp on my camera feed logs.

  • @super_kev I believe you're trying to solve the "Timestamps are unset in a packet" error in your previous ffmpeg error log?

    The timestamps ffmpeg want is not the visual timestamps generated by the camera, but somekind of integrated timestamp in the raw video stream.
    I believe most H264 video streams does not contain this, and the error can be ignored.

    Regarding the font path, i think it needs the whole path of the .ttf file.
    It seems so with the default path in the monitor settings.

  • Gotcha, yes I was hoping that would fix it, but also just noticed that it doesn't seem to work on my end regardless. I entered the full path of the font file (OS X ) like this:

    Macintosh HD/Users/username/Shinobi/FreeSans.ttf

    but still no go to get the timestamp to show up, including changing font size and color.

  • Hi, I can't make the timestamp work on Ubuntu box too.
    Anyone please share your solution.


Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.