Configure Monitor - Path greyed out



  • Hi ... I've just set up Shinobi but I am struggling with setting up a monitor.
    I can use VLC for example to display the stream from my camera, but I cannot enter the correct data in Shinobi, because "Path" is greyed out:

    0_1514678891734_a0845238-298a-4517-9ca3-21de5c7506df-image.png

    The RTSP url is rtsp://user:[email protected]:554/live/ch1 so I guess that videostream.cgi?1 has to be changed to something else?

    Using "Probe" returns a lot of data from the camera so RTSP should be working.
    But how to configure the monitor's options then?

    Thanks!



  • It's not grayed out, it's an example of what you should put there. In my case with some Hikvision cams, rtsp://login:[email protected]/video.h264, as the pathway was /video.h264 so I would assume your url should be something like /live/ch1

    You can go to the Camera URLs page (at bottom of Shinobi Docs) Clicky. Look up your camera, find the url and paste it in the path, then click probe and see if you still get data, if not, work at it until you find the probe url feed that works, but I would bet it's /live/ch1 if your probe is returning data.



  • Thanks.
    It's a Wansview W2 and should work according to the docs.
    The problem is that I cannot paste it because the example (/videostream.cgi?1) cannot be overwritten / changed.



  • What's your input type and connection type?



  • I've tried various settings.
    Currently it's set to (according to https://shinobi.video/docs/cameras/Wansview - I am using the W2)
    Input Type: H.264
    Connection Type: RTSP
    (I was able to enter the Path now - I haven't changed anything, but rebooted the box).

    That's what I have found in the logs

    Uncaught Exception occured!
    Error: EACCES: permission denied, mkdir '/dev/shm/streams/2Df5hBE/xxx/'
        at Object.fs.mkdirSync (fs.js:885:18)
        at Object.s.camera (/usr/src/shinobi/shinobi/camera.js:1367:20)
        at Timeout._onTimeout (/usr/src/shinobi/shinobi/camera.js:3824:90)
        at ontimeout (timers.js:475:11)
        at tryOnTimeout (timers.js:310:5)
        at Timer.listOnTimeout (timers.js:270:5)
    1
    

    Solved it by adjusting permissions.

    But it still shows just a black screen:

    0_1514887955515_4990d9dc-becc-4e7f-bf47-7a2a7d85dce4-image.png
    I've found https://shinobi.video/articles/2017-08-12-my-stream-appears-black-or-just-a-solid-color so working on it.
    Will update the thread after I've read the article 🙂

    Update
    I enabled SQL logging and now I see

    {"type":"Process Unexpected Exit","msg":{"msg":"Process Crashed for Monitor : MYMONITOR","cmd":"-loglevel warning -analyzeduration 100000 -probesize 100000 -i rtsp://MYUSERNAME:[email protected]:554/live/ch1 -update 1 -r 1 -s 640x360 /dev/shm/streams/2Df5hBE/MYMONITOR/s.jpg -y -f mpegts  -c:v no -c:a aac http://127.0.0.1:8080/streamIn/2Df5hBE/MYMONITOR/1"}}                                                                                                                               
    

    How to troubleshoot that?



  • When I am running ffmpeg with the parameters from the log

    ffmpeg -loglevel warning -analyzeduration 100000 -probesize 100000 -i rtsp://USER:[email protected]:554/live/ch1 -update 1 -r 1 -s 640x360 /dev/shm/streams/2Df5hBE/MONITOR/s.jpg -y -f mpegts  -c:v no -c:a aac http://127.0.0.1:8080/streamIn/2Df5hBE/MONITOR/1
    

    I get the following output

    Unknown encoder 'no'
    

    Ideas?



  • @hooch You have not defined which codec to be used for the stream video ?
    Try HLS, video codec: copy
    To begin with


  • administrators

    @hooch said in Configure Monitor - Path greyed out:

    probe

    oh hey... thanks for that.. that looks like a bug with the options.

    For now please use copy or libx264


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.