Recording FPS, Width, Height not present



  • Per Shinobi docs (https://shinobi.video/docs/settings), in Monitor Settings - Record I should see and be able to edit Video Record Rate, Record Width, and Record Height, but I am not seeing those three items in my version of Shinobi built per instructions (OS X ) a few days ago.

    0_1514044366105_Recording1.jpg

    1_1514044366106_Recording2.jpg


  • administrators

    Sorry it looks like i missed changing the git link for that install process to the Pro repo. This was fixed in the Pro repo already.

    git clone https://github.com/moeiscool/shinobi Shinobi && cd Shinobi
    

    should be

    git clone https://github.com/ShinobiCCTV/Shinobi Shinobi
    

    To switch you can follow these steps. First navigate to the parent directory of where Shinobi is. So if Shinobi is cd /home/Shinobi then do cd /home.

    Notice -b dev at the end of the git clone command, you can get the latest changes by doing that. Not using -b dev will default to master.

    cd /home
    pm2 kill
    mv Shinobi Shinobi.old
    git clone https://github.com/ShinobiCCTV/Shinobi Shinobi -b dev
    cd Shinobi
    npm install
    cp ../Shinobi.old/conf.json conf.json
    cp ../Shinobi.old/super.json super.json
    pm2 start camera.js
    pm2 start cron.js
    


  • Ok that fixed it, now I can record but holy smokes CPU gets eaten up, I'm running 390% while using the default x264 processing agent at 2048x1536, 10fps. Going to mp4/copy fixed that though, and file sizes aren't that bad, yet.

    So on OS X, Shinobi is installed in the root home folder (alongside Desktop, Documents, Pictures, etc. folders). When you open Terminal should load the proper pathway to start, and so the cd /home command is not needed, at least not on my machine.

    Got another problem... on my test machine/laptop, I didn't have this error, but on a brand new OS X install (got a dedicated Mini for this, fresh erase/install of 11.4), when opening Terminal and running the

    git clone https://github.com/ShinobiCCTV/Shinobi Shinobi
    

    command, Terminal reports a permissions error at the end:

    Cloning into 'Shinobi'...
    remote: Counting objects: 1336, done.
    remote: Compressing objects: 100% (86/86), done.
    remote: Total 1336 (delta 70), reused 90 (delta 37), pack-reused 1211
    Receiving objects: 100% (1336/1336), 4.14 MiB | 2.95 MiB/s, done.
    Resolving deltas: 100% (763/763), done.
    warning: unable to access '/Users/osxusernamehere/.config/git/attributes': Permission denied
    

    Any ideas on what the hidden config folder does and how to fix it?


 

Looks like your connection to Shinobi Forum was lost, please wait while we try to reconnect.